2014-09-29

SSD 換装で、大コケにコケた話。

ツクモの日 (9月19日) で、特価になっていた Crucial MX100 256GB [CT256MX100SSD1] を購入し、Dell Inspiron 11 (3138) に換装しようとした時に大コケにコケた話の覚書。


解決まで、ずいぶんと時間がかかりました。ようやくノートPCが使えますε-(´∀`*)ホッ
もうこんな思いはしたくないですね。

[ 2014/09/30 追記 ]
暫く出なかったので、大丈夫かと思ったら不完全でした…… まだ同じ症状が出続けています。

[ 2014/10/01 追記 ]
「(7) EaseUS Todo Backup Free のアンインストール」の項目を追加しました。現在テスト中。

[ 2014/10/13 追記 ]
テストを一週間以上続けてきましたが、症状が再発することはありませんでした!
無事解決と言っていいのではないでしょうか。

[ 2016/10/22 追記 ]
様々なページからリンクが張られ、参照数も増え非常に嬉しく感じています。
どんな記事を書かれているか、眺めさせてもらっているのですが、レジストリを弄ったあとにクローニングソフトのアンインストールを試しておられるパターンが多いです。 (まぁ、この記事の日記形式で書き足しし続けた書き方も悪いのですが。)
素直に上から読んでくださっているのはとてもありがたいのですが、ディスク I/O が 100% になる症状はクローニングソフトをアンインストールするだけで問題は解決する可能性が高いので、まずクローニングソフトのアンインストールだけ試されることをオススメします。それでもダメな場合にレジストリ変更を試してみてください。



(1) EaseUS Todo Backup Free でのクローニング


初めは、元々の HDD から EaseUS Todo Backup Free でクローニングを行ったのですが、見事失敗w

クローニングは行えている様子だったけれど、ドライブレターが付くべきではないドライブについてしまい、ドライブレターがずれて、ブート構成データとの整合性が取れなくなる (と個人的に結論づけた) 症状が発生。
そんなわけで、換装して載せ替えるだけじゃ動かず (エラー 0x00000225)、DISKPART (ドライブレターの変更) + BCDboot (ブート構成データの再構成) で直した。

使ったコマンドたち。
>diskpartDISKPART の起動
DISKPART> list volumeボリュームの表示
DISKPART> select volume 0ボリューム 0 の選択
DISKPART> remove letter=cドライブレター C: の除去
DISKPART> assign letter=cドライブレター C: の割り当て
DISKPART> exitDISKPART の終了
>bcdboot C:\Windows /s Z: /f UEFIシステムドライブ C: のブート構成データを Z: に再構成
# 参照: エラーコード0xc0000225の解決策(Windows 8/8.1)


起動はしたものの、挙動がおかしいのでやり直すことに。 (一番判断しやすかったのが、回復パーティションを認識していないこと。出荷状態に戻すことも不可能に。)

これを何回かやってみたものの、なんか上手く行かず。



(2) Acronis True Image HD でのクローニング


EaseUS Todo Backup Free でのときと同じようにクローニング。
SSD に付属していたツール。登録が面倒だったので使っていなかったが、仕方なく使うことに。

ドライブレターの問題は発生しなかった。コレはキタ! と思ったのですが、なんか挙動がおかしい感じ。(結論から言えば、Acronis True Image のクローニングは完璧だった。)



(3) Windows の再インストール


★ 事前に作成しておいたリカバリディスクからのリカバリ

なんか挙動がおかしいので、OS の再インストールしたほうがいいんじゃないかと思うように。

が……

「お使いのハードドライブの容量では、この作業を行うことができません。
465 GB以上の容量のあるハードドライブを使用してください。」

Dell のリカバリディスク使えねぇぇぇorz

終了。……というわけにはいかないので、次の手段に。


★ 正常な HDD を出荷状態にし、それをクローニング

このあたりから迷走開始。
SSD を取り外して、HDD を PC に戻し、工場出荷状態にし、再度クローニングを実行。

色々とアプリケーション詰め込んだ頃に、ディスク使用率が 100% になって、フリーズする症状が出てくるように。

というわけで、次。


★ 普通の Windows 8.1 インストールディスクからの再インストール

Windows 8 系のメーカ PC は、適当な Windows 8 系インストールディスクで OS のインストールを行っても、自動的にキーが入り、ライセンス認証が行われることを思い出し、Windows 8.1 のインストールディスクからインストールを実行。

インストールは、ライセンス認証含め成功。

それでも、やっぱり同じような症状が。

# もし、Windows 8.x 系プリインストール PC で、インストールディスクを失くした or リカバリディスクを作り忘れて HDD/SSD が死んだ場合には、適当な Windows 8.x 系インストールディスクを用意すれば、問題なく OS をインストール可能。OS 標準ドライバは動かない、Windows Update で用意されていない、リカバリイメージにしか入っていない、サポートページにアップデータがないような、特殊なデバイスドライバを除けば、実用上も問題ないかと。 Windows 8.x 系 OEM PC には、ロジックボード上に認証用のチップが載ってて、勝手にそこに書き込まれたキーで認証が通ってしまうんですよね。便利ですが、困る場合 (ディスクでの無印→Proへのアップグレード、まぁ、キーを入れなおせばよかったはず) もあるとかないとか。







色々とやっているうちに、結論に近づき始めていた。
そう、「SSD (Crucial MX100) と PC (Inspiron 11) の相性が悪い」ということに。←遅い

症状はディスク使用率が 100% になり、身動きが取れなくなるというもの。
これをヒントに調べ回りました。

ディスクへの書き込みがほぼ行えなくなるので、スクリーンショットすら保存できなかったんですよね……



(4) サービスを弄る


結論から言えば、関係なく、症状は全く改善されなかった。
詳しいことを知りたい方はググってみて欲しい。



更に調査を進めると、昔の SSD でよくあった「プチフリ (プチフリーズ)」の症状に近いことがわかってきた。
特に、LPM 周りが怪しそうであるということ。

例えば、この辺↓
[PCトラブル記]やっと原因がわかった!Windows7+H67+SATA6Gbpsの環境で、Crucial SSD C300を使うとフリーズしまくった件

世代は違えど、Crucial の SSD だし。
Crucial MX100 は、LPM (Link Power Management) の HIPM (Host Initiated Link Power Management) には対応していないので、この電源管理周りが悪さをしているのは、挙動からも納得できたので。

因みに DIPM (Device Initiated Link Power Management) には対応しているらしい。ただ、使おうとしたらやっぱり挙動がおかしくなった。きちんと設定を弄ればいいのかもだが、面倒だし、別に要らなさそうだし、もう疲れたので、頑張れる人は頑張ってください。



(5) LPM (Link Power Management) 周りを弄る


まず、レジストリを弄る。下の枠内をコピーし、テキストエディタに貼り付けて、拡張子を .reg にして保存し、実行。
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\0b2d69d7-a2a1-449c-9680-f91c70521c60]
"Attributes"=dword:00000000
# 作るのが面倒な方は、LPM.reg をダウンロードして使って下さい。

続いて、「コントロール パネル」から「電源オプション」を開く。
弄るのは、標準の「バランス」がいいかと。「プラン設定の変更」をクリック。



「詳細な電源設定の変更」から、「ハードディスク」-「AHCI Link Power Management - HIPM/DIPM」と「次の時間が経過後ハード ディスクの電源を切る」の設定を下の画像のように変える。 (前者は全て "Active"、後者は "0" を入力して "なし" に。)


面倒でなければ、同じように、別のプランも弄っておくと安心。

Dell PC の場合には「デル拡張バッテリー駆動時間オプション」の「バッテリステータス」タブ内の「デル拡張バッテリ時間の有効化」の設定で、「電源プランを省電力に変更」のチェックが外れているか確認したほうがいい。全てのプランの設定を変えてあれば問題ないが、もしそうでない場合には悲劇が起きる。

# 参考: Windows7マシンがなんとなく不調」な場合の解決方法をリストアップ ほか







これで改善されれば、それはそれでいいのだが、私の環境では完全に解決しなかったので、更にもう一歩。



(6) AHCI (Advanced Host Controller Interface) 周りを弄る


またまた、レジストリを弄ります。Windows キー + R で「ファイル名を指定して実行」を開き、"regedit" と打ち込む。そして、下のレジストリパスを開く。
HKEY_LOCAL_MACHINE¥SYSTEM¥CurrentControlSet¥Services¥storahci
# Windows 7 では、msahci だったみたいだけど、Windows 8.x では storahci に変わったよう。


storahci 内の、「ErrorControl」のデータを "0" に変える。 (私の環境では元々 3 だった。)


続いて、「StartOverride」を下の画像のようにする。 (元々ある場合もあるみたいだが、私の環境ではなかったので作った。名前「0」、データ "0" のエントリを作るのを忘れずに。)

# 参考: AHCI for Windows 8.1 and 8 via storahci (activate, switch)

もしくは、下の内容をテキストファイルに貼り、拡張子を .reg にして実行してもOK。(iaStorV は RAID 用らしいので、なくてもいいかも。Controller0~3 は上の説明では出てきていませんが、接続したドライブのポートに合わせて入れておいた方が良さそう。)
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV]
"ErrorControl"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\StartOverride]
"0"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci]
"ErrorControl"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Controller0]
"DipmEnabled"=hex:00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Controller1]
"DipmEnabled"=hex:00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Controller2]
"DipmEnabled"=hex:00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Controller3]
"DipmEnabled"=hex:00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride]
"0"=dword:00000000
# 作るのが面倒な方は、AHCI.reg をダウンロードして使って下さい。

調べた限りでの Intel Rapid Storage Technology 周りのドライバについて。
iaStor は Intel 製のドライバで、iaStorV は Microsoft 製のドライバだそうな。
iaStorA は iaStor の新しいもの (リネームされたもの) のよう。また、命名規則的に iaStorAV は Microsoft によるドライバっぽい。
iaStorF なる Intel 製ドライバもあるみたいだが、フィルタらしい。iaStorA あたりとセットっぽい。ま、よくわかんないけど。
iaStorS は Intel 製 SAS 用ドライバらしい。コレに関してはもう関係ないけど。







(7) EaseUS Todo Backup Free のアンインストール


直ったかと思ったら、やっぱり症状が出たので、引き続き調査を続けていたところ、新たな情報を発見。

MX100 SSD Freezes After 8.1 (KB2919355) - Crucial Community

読んでみると、付属の Acronis True Image HD の自動バックアップ用サービスが悪さをしていて、サービスを止めたら直った的なことが。
システムの環境も近い (コントローラが "Intel(R) Pentium(R) processor N- and J-series / Intel(R) Celeron(R) processor N- and J-series AHCI - 0F23") ので、これは考えうるパターン。

ただ、インストールしてあるのは、Acronis True Image HD ではなく、EaseUS Todo Backup Free。バックアップ系の競合ソフトではある。
これまでの状況をよくよく思い出してみると、システム再構築時にバックアップ系のアプリケーションは最後の最後に入れていたので、原因である可能性は否定できない。

そんなわけで、アンインストールして、様子を見ている段階です。後日、状況報告を行いたいと思います。
また、サービスを止める形でも検証する気になったらします(笑)


→ どうやら、解決した様子です。今度こそ、安心して PC を使い潰せますw




16 件のコメント :

  1. こんばんは、検索から来ました。
    intel 120GB SSDからクルーシャルのMX200に換装したのですが、原因不明のフリーズで困っていたところ、EaseUS Todo Backup Freeをアンインストールで解決しました。
    すっごく助かりました!!

    返信削除
    返信
    1. 御影ビギさん、はじめまして!
      私、このブログを管理している tag というものです。

      現行モデルの MX200 でも、同じ問題が発生するんですね(^_^;
      お役に立てて何よりです^^

      削除
  2. Windows10にアップデートしてから、本事象になり原因不明でもやもやしていたところ
    最終的にこの記事にたどり着きました!MX100なのですがEaseUS Todo Backup Freeをアンインストールで解決しました。ありがとうございます!

    返信削除
    返信
    1. # 返信が随分遅くなってしまいましたが……
      無事解決したようで何よりです!

      削除
  3. お世話になっております。EaseUS SoftwareのTeiと申します。

    御サイト上で弊社の製品をご紹介頂きありがとうございました。
    ちょっとお願いしたいことがございますが、記事中にEaseUS Todo Backupを日本語公式ページをご挿入頂けませんでしょうか。

    http://jp.easeus.com/backup-software/free.html

    お手数をお掛けまして、すみません。
    どうぞよろしくお願い致します。

    返信削除
    返信
    1. EaseUS Software Tei さん
      (この記事では悪者になっていますが) いくらかお世話になったアプリケーションでもあるので、リンクを貼りました。ご確認ください。

      削除
    2. リンクはちょっと確認できないようですが。。。大変お手数ですが、もう一度確認できませんでしょうか。

      削除
    3. リンクアドレスが誤っていたようです。遅くなりましたが、修正しましたので、ご確認ください。

      削除
  4. crucial MX300 CT275MX300SSD1です 去年お友達のパソコンをセットしたとき面倒だからクローンにしました、HDD100%同じ現象フリーズします、私のパソコンと丸ごと交換して解決していたのですが、このSSDもう一度使ってみることにしました、やっぱり!数分で100%でフリーズします、ファームアップしても何も変わらず、こちらに行きついて上から順番に試しましたが変わらず?最後に、EaseUS Todo Backup Freeをアンインストールで解決しました、ありがとうございました。

    返信削除
    返信
    1. syouta023 さん
      無事解決したようで何よりです!

      削除
    2. はい、ありがとうございます、crucial MX300 CT275MX300SSD1は2カ月で7,300円~9,300円に値上がりしていました。

      削除
  5. このコメントは投稿者によって削除されました。

    返信削除
  6. Lenovo G560 のHDDを crucial MX300 CT525 に換装後、全く同じ現象になり困っていました。EaseUS Todo Backup Freeをアンインストールで解決しました。ありがとうございました!

    返信削除
    返信
    1. NWさん
      お役に立てたようで何よりです!
      MX300でも起きるんですね……

      削除
  7. とりとめもないはなし。 管理人様

    お世話になっております。EaseUS Softwareです。

    お忙しい中またお邪魔致しまして、申し訳ございません。

    御サイト上で弊社製品をご紹介頂きまして重ねて感謝しております。

    先日、弊社日本語公式サイトをSSL化にしましたので、お知らせいたします。

    お手数ですが、記事中のリンク先をhttpsページにご修正頂けませんでしょうか?

    お忙しいところ大変恐縮でございますが、ご確認の上、ご検討頂けば幸いに存じます。

    何とぞよろしくお願い致します。

    返信削除
    返信
    1. EaseUS Software Robin Jia さん

      修正しましたので、ご確認ください。

      削除